<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.heraldpubs.com/wp-content/cache/borlabs_cache/1/js/f42a1ae719ca59f1107c373f47a18b50f8346d50_https.js" as="script">
<link rel="preload" href="https://www.heraldpubs.com/wp-content/cache/borlabs_cache/1/css/e1b9ad2e2510ee5db1b23ed27824f56f7bd21da7_https.css" as="style">
<link rel="stylesheet" href="https://www.heraldpubs.com/wp-content/cache/borlabs_cache/1/css/e1b9ad2e2510ee5db1b23ed27824f56f7bd21da7_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="http://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.heraldpubs.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.heraldpubs.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.heraldpubs.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Gov. Pritzker Announces $327 Million in Household Assistance Available for Low-Income Families in Illinois &#8211; Herald Publications</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="Herald Publications &raquo; Feed" href="https://www.heraldpubs.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Herald Publications &raquo; Comments Feed" href="https://www.heraldpubs.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="Herald Publications &raquo; Gov. Pritzker Announces $327 Million in Household Assistance Available for Low-Income Families in Illinois Comments Feed" href="https://www.heraldpubs.com/2021/09/20/gov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois/feed/" /> <meta property="og:title" content="Gov. Pritzker Announces $327 Million in Household Assistance Available for Low-Income Families in Illinois"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.heraldpubs.com/2021/09/20/gov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois/"/><meta property="og:site_name" content="Herald Publications"/><meta property="og:image" content="https://www.heraldpubs.com/wp-content/uploads/2021/09/money.jpg"/>                       <style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.heraldpubs.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                        <link rel="https://api.w.org/" href="https://www.heraldpubs.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.heraldpubs.com/wp-json/wp/v2/posts/271916" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.heraldpubs.com/xmlrpc.php?rsd" /> <link rel='prev' title='State Reaches First Union Agreement For Vaccine Mandate in Illinois’ Congregate Facilities' href='https://www.heraldpubs.com/2021/09/20/state-reaches-first-union-agreement-for-vaccine-mandate-in-illinois-congregate-facilities/' /> <link rel='next' title='Illinois’ eviction moratorium set to expire Oct. 3' href='https://www.heraldpubs.com/2021/09/20/illinois-eviction-moratorium-set-to-expire-oct-3/' /> <link rel="canonical" href="https://www.heraldpubs.com/2021/09/20/gov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois/" /> <link rel='shortlink' href='https://www.heraldpubs.com/?p=271916' /> <link rel="alternate" type="application/json+oembed" href="https://www.heraldpubs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.heraldpubs.com%2F2021%2F09%2F20%2Fgov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.heraldpubs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.heraldpubs.com%2F2021%2F09%2F20%2Fgov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:300px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.heraldpubs.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>  <style id="wp-custom-css">
			

/*
CSS Migrated from BB theme:
*/

.fl-post-author {
    display: none;
}

		</style> <script src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script src='https://www.google.com/recaptcha/api.js?ver=5.5.6' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.heraldpubs.com/wp-content/cache/borlabs_cache/1/js/f42a1ae719ca59f1107c373f47a18b50f8346d50_https.js"></script></head> <body class="post-template-default single single-post postid-271916 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-framework-bootstrap fl-preset-color01 fl-fixed-width fl-has-sidebar" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"><div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-top-bar-menu" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-284 nav-item"><a href="https://www.heraldpubs.com/contact-us/" class="nav-link">Contact Us</a></li> <li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-285 nav-item"><a class="nav-link">E-Edition</a> <ul class="sub-menu"> <li id="menu-item-15592" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15592 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=c217e653-d6dd-4728-9c50-c9ad4133dfd2" class="nav-link">Scott Flier</a></li> <li id="menu-item-15593" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15593 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=d5fec356-fe7f-4ae9-aba1-cf00f92d6bf4" class="nav-link">The Herald</a></li> <li id="menu-item-15594" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15594 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=2d229e9e-3c6f-4210-bf52-883dd4b47deb" class="nav-link">The Tribune</a></li> </ul> </li> <li id="menu-item-286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-286 nav-item"><a class="nav-link">Subscribe</a> <ul class="sub-menu"> <li id="menu-item-15596" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15596 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=c217e653-d6dd-4728-9c50-c9ad4133dfd2&#038;view=subscribe" class="nav-link">Scott Flier</a></li> <li id="menu-item-15597" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15597 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=d5fec356-fe7f-4ae9-aba1-cf00f92d6bf4&#038;view=subscribe" class="nav-link">The Herald</a></li> <li id="menu-item-15598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15598 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=2d229e9e-3c6f-4210-bf52-883dd4b47deb&#038;view=subscribe" class="nav-link">The Tribune</a></li> </ul> </li> <li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-287 nav-item"><a class="nav-link">Archives</a> <ul class="sub-menu"> <li id="menu-item-15599" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15599 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=bb506c23-78c3-4655-a1ad-acbbd367017d&#038;view=archives" class="nav-link">The Clinton County News</a></li> <li id="menu-item-15600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15600 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=c217e653-d6dd-4728-9c50-c9ad4133dfd2&#038;view=archives" class="nav-link">Scott Flier</a></li> <li id="menu-item-15601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15601 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=d5fec356-fe7f-4ae9-aba1-cf00f92d6bf4&#038;view=archives" class="nav-link">The Herald</a></li> <li id="menu-item-15602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15602 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=2d229e9e-3c6f-4210-bf52-883dd4b47deb&#038;view=archives" class="nav-link">The Tribune</a></li> </ul> </li> </ul> <div class="fl-social-icons"> <a href="mailto:heraldpubs@heraldpubs.com" rel="noopener noreferrer"><span class="sr-only">Email</span><i aria-hidden="true" class="fas fa-envelope mono"></i></a></div> </div> </div> </div> </div> </div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.heraldpubs.com" itemprop="url"><img loading="false" data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://www.heraldpubs.com/wp-content/uploads/2016/08/finalmastaddress2png.png" data-retina="" title="" alt="Herald Publications" /><meta itemprop="name" content="Herald Publications" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-62258" class="widget widget-webads-weather"> <a id="webads-weather-62258-link" href="https://www.heraldpubs.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-62258-temperature" class="temperature"></span> <i id="webads-weather-62258-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-62258-location" class="location"></span> <span id="webads-weather-62258-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form aria-label="Search" method="get" role="search" action="https://www.heraldpubs.com/" title="Type and press Enter to search."> <input aria-label="Search" type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" onfocus="if (this.value === 'Search') { this.value = ''; }" onblur="if (this.value === '') this.value='Search';" /> </form> </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076 nav-item"><a href="https://www.heraldpubs.com/" class="nav-link">Home</a></li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296 nav-item"><a class="nav-link">E-Edition</a> <ul class="sub-menu"> <li id="menu-item-15584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15584 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=c217e653-d6dd-4728-9c50-c9ad4133dfd2" class="nav-link">Scott Flier</a></li> <li id="menu-item-15585" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15585 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=d5fec356-fe7f-4ae9-aba1-cf00f92d6bf4" class="nav-link">The Herald</a></li> <li id="menu-item-15586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15586 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=2d229e9e-3c6f-4210-bf52-883dd4b47deb" class="nav-link">The Tribune</a></li> </ul> </li> <li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-297 nav-item"><a class="nav-link">Subscribe</a> <ul class="sub-menu"> <li id="menu-item-15588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15588 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=c217e653-d6dd-4728-9c50-c9ad4133dfd2&#038;view=subscribe" class="nav-link">Scott Flier</a></li> <li id="menu-item-15589" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15589 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=d5fec356-fe7f-4ae9-aba1-cf00f92d6bf4&#038;view=subscribe" class="nav-link">The Herald</a></li> <li id="menu-item-15590" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15590 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=2d229e9e-3c6f-4210-bf52-883dd4b47deb&#038;view=subscribe" class="nav-link">The Tribune</a></li> </ul> </li> <li id="menu-item-18247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18247 nav-item"><a href="https://www.heraldpubs.com/sound-off/" class="nav-link">Sound Off</a></li> <li id="menu-item-267657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267657 nav-item"><a href="https://www.heraldpubs.com/thumbs-up/" class="nav-link">Thumbs Up</a></li> <li id="menu-item-264772" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-264772 nav-item"><a href="https://www.heraldpubs.com/obituaries/" class="nav-link">Obituaries</a></li> <li id="menu-item-267344" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-267344 nav-item"><a href="#" class="nav-link">Submissions</a> <ul class="sub-menu"> <li id="menu-item-20074" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20074 nav-item"><a href="https://www.heraldpubs.com/special-event-form/" class="nav-link">Special Events Form</a></li> </ul> </li> <li id="menu-item-190174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-190174 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.lincolntheatre-belleville.com/" class="nav-link">Movies</a></li> <li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293 nav-item"><a href="https://www.heraldpubs.com/photos/" class="nav-link">Photos</a></li> <li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290 nav-item"><a href="https://www.heraldpubs.com/event-calendar/" class="nav-link">Events</a></li> <li id="menu-item-4243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4243 nav-item"><a href="#" class="nav-link">Regional News</a> <ul class="sub-menu"> <li id="menu-item-4246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4246 nav-item"><a href="https://www.heraldpubs.com/illinois-news/" class="nav-link">Illinois News</a></li> <li id="menu-item-4244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4244 nav-item"><a href="https://www.heraldpubs.com/st-louis-news/" class="nav-link">St. Louis News</a></li> <li id="menu-item-20095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20095 nav-item"><a href="https://www.heraldpubs.com/southwestern-illinois-college/" class="nav-link">Southwestern Illinois College</a></li> <li id="menu-item-20093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20093 nav-item"><a href="https://www.heraldpubs.com/southern-illinois-university-edwardsville/" class="nav-link">Southern Illinois University-Edwardsville</a></li> <li id="menu-item-20092" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20092 nav-item"><a href="https://www.heraldpubs.com/kaskaskia-college/" class="nav-link">Kaskaskia College</a></li> <li id="menu-item-20096" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20096 nav-item"><a href="https://www.heraldpubs.com/mid-america-airport/" class="nav-link">Mid America Airport</a></li> <li id="menu-item-20094" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20094 nav-item"><a href="https://www.heraldpubs.com/mckendree-university/" class="nav-link">McKendree University</a></li> <li id="menu-item-20091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20091 nav-item"><a href="https://www.heraldpubs.com/scott-air-force-base/" class="nav-link">Scott Air Force Base</a></li> </ul> </li> <li id="menu-item-264164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264164 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.publicnoticeillinois.com" class="nav-link">Legals</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.heraldpubs.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-271916 post type-post status-publish format-standard has-post-thumbnail hentry category-state-news" id="fl-post-271916" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Gov. Pritzker Announces $327 Million in Household Assistance Available for Low-Income Families in Illinois </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.heraldpubs.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-09-20">September 20, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.heraldpubs.com/2021/09/20/gov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois/#respond" tabindex="-1" aria-hidden="true">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.heraldpubs.com/wp-content/uploads/2021/09/money.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <p><em><strong>LIHEAP and CSBG Programs to Provide Historic Levels of Assistance to More Residents in Need than Ever Before</strong></em></p> <p>PEORIA &#8211; Governor JB Pritzker today joined the Illinois Department of Commerce and Economic Opportunity (DCEO) and community partners to announce $327 million in Help Illinois Families assistance now available through the Low-Income Household Energy Assistance Program (LIHEAP) and the Community Services Block Grant Program (CSBG). The program offers expanded services to support Illinois’ most vulnerable residents with rent, utilities, food and other household expenses regardless of immigration status.</p> <p>With support from the American Rescue Plan Act and increased eligibility provisions by the State of Illinois, residents will have access to more utility assistance than ever before, as well as increased availability of funds per household. The State is leveraging $209 million from the American Rescue Plan Act (ARPA) to expand relief for Illinois families struggling to pay their bills as a result of the COVID-19 crisis. LIHEAP funds are available from now through May 31, 2022. To apply, please go to DCEO’s website or visit helpillinoisfamilies.com.</p> <p>“This year, the State of Illinois is offering $327 million in community assistance programs for low-income families. That includes the latest round of our Low-Income Household Energy Assistance Program and the Community Services Block Grant Program,” said Governor JB Pritzker. “We are offering residents in need more access than ever before to vital safety net programs that can prevent them from falling behind on payments, falling into debt, or risking their ability to get back to work. Overall, this $327 million investment represents a $52 million increase over last year’s programs. It’s a historic investment to meet a historic moment.”</p> <p>To respond to the increased need that emerged during COVID-19, DCEO has implemented new permanent requirements put in place via SB0265 to increase the income threshold and to broaden eligibility for households regardless of immigration status. With more funds available, this year’s LIHEAP program will increase payments per household – with an anticipated average payment of $1,000 in the program year 2022, up from the average of $750 last year.</p> <p>“For families struggling to make ends meet, the State of Illinois is offering assistance with paying utility bills and other safety net services to help more residents get back on their feet,” said DCEO Acting Director Sylvia Garcia. “Thanks to action taken by Governor Pritzker, the Illinois General Assembly, and with the committed service of 37 statewide Community Action Agencies – we have increased access to programs that can offset the cost of monthly bills. We are encouraging residents to get in touch with DCEO and our partners today and to apply for assistance while funds remain.”</p> <p>SB 0265 also takes steps to codify changes made last year to ensure that, for the first time in state history, LIHEAP assistance would be made accessible for any Illinois resident with a utility bill in their name if they meet the income eligibility requirements.</p> <p>Additional utility assistance/relief currently available by the State of Illinois builds on a record year in 2021, where over $343 million in assistance was provided to over 289,000 families statewide. Last year the State leveraged additional funding from the CARES Act, in addition to state funds, including $112 million in Utility Disconnection Avoidance Program to supplement the urgent needs of families seen in the early months of the pandemic.</p> <p>The “Help Illinois Families” program was created to expand the reach of the State’s Low-Income Home Energy Assistance Program (LIHEAP) and Community Services Block Grant (CSBG) programs during the pandemic.</p> <p>To encourage Illinois families to apply, the Governor joined Peoria Citizens Committee for Economic Opportunity, one of the 37 CAA’s providing services to all 102 Illinois counties to help residents receive LIHEAP and community assistance payments.</p> <p>Through the Peoria Citizens Committee for Economic Opportunity, Inc., a member of the National Community Action Partnership, we are promoting transformational help to individuals, improving their quality of life by offering support services in times needed most,” said McFarland A. Bragg II, President and CEO of PCCEO. “Programs like LIHEAP and CSBG provide residents with a rapid response and access to assistance for items like utility bills, rent and food, especially when we move into the colder months ahead.”</p> <p>&#8220;Hundreds of thousands of Illinois customers struggled to afford their monthly utility bills prior to the COVID-19 pandemic, when that inability to afford life essentials was made exponentially worse,” said Karen Lusson, staff attorney at the National Consumer Law Center. &#8220;The enhanced state and federal assistance offered through LIHEAP and the recent expansions of the PIPP program are needed now more than ever.”</p> <p>“Unfortunately, far too many families around the state cannot afford to adequately heat their homes when especially when temperatures start to drop,” said State Representative Jehan Gordan-Booth (D-Peoria). “Residents shouldn’t be forced to choose between heating their homes or paying for their next meal. Thank you, Governor Pritzker, for ensuring we maximize this vital lifeline so more families and are able to receive additional support through LIHEAP.”</p> <p>To qualify for LIHEAP, households must demonstrate if they meet the expanded income requirements of 200 percent of the poverty level, regardless of immigration status. Recommended documents for application include Social Security Number, or I-TIN, or other identification, and proof of income. Applicants need to supply their utility bill for LIHEAP and lease for rental assistance.</p> <p>To help families avoid a service shutoff last year, DCEO last year took steps to expand LIHEAP eligibility, increase funding and to make the application process easier for residents. These changes were adopted as part of Governor Pritzker’s “Help Illinois Families” initiative – designed to expand the reach of the State’s Low-Income Home Energy Assistance Program (LIHEAP) and Community Services Block Grant (CSBG) programs in the wake of the pandemic. Help Illinois Families offers expanded services to support Illinois’ most vulnerable residents with rent, utilities, food and other household expenses regardless of immigration status.</p> <p>The remote application for LIHEAP and CSBG is available now on helpillinoisfamilies.com. To help eliminate any barriers to the application process, the State also provides a hotline service with multilingual assistance in over 30 languages. Residents may visit their local CAA in-person or call the hotline at 1-833-711-0374.</p> <p>For more information about the relief programs, visit the DCEO website.</p> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.heraldpubs.com/2021/09/20/gov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois/" data-a2a-title="Gov. Pritzker Announces $327 Million in Household Assistance Available for Low-Income Families in Illinois"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.heraldpubs.com%2F2021%2F09%2F20%2Fgov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois%2F&amp;linkname=Gov.%20Pritzker%20Announces%20%24327%20Million%20in%20Household%20Assistance%20Available%20for%20Low-Income%20Families%20in%20Illinois" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.heraldpubs.com%2F2021%2F09%2F20%2Fgov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois%2F&amp;linkname=Gov.%20Pritzker%20Announces%20%24327%20Million%20in%20Household%20Assistance%20Available%20for%20Low-Income%20Families%20in%20Illinois" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.heraldpubs.com/category/state-news/" rel="category tag">State News</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.heraldpubs.com/wp-comments-post.php" method="post"> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='271916' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <input type="hidden" id="ct_checkjs_ab817c9349cf9c4f6877e1894a1faa00" name="ct_checkjs" value="0" /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/09/20/gov-pritzker-announces-327-million-in-household-assistance-available-for-low-income-families-in-illinois/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.heraldpubs.com/2021/09/20/illinois-eviction-moratorium-set-to-expire-oct-3/" rel="bookmark" title="Illinois’ eviction moratorium set to expire Oct. 3"> <img width="300" height="300" src="https://www.heraldpubs.com/wp-content/uploads/2021/09/Eviction-Moratorium-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.heraldpubs.com/2021/09/20/illinois-eviction-moratorium-set-to-expire-oct-3/" rel="bookmark" title="Illinois’ eviction moratorium set to expire Oct. 3">Illinois’ eviction moratorium set to expire Oct. 3</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 20, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.heraldpubs.com/2021/09/20/illinois-eviction-moratorium-set-to-expire-oct-3/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.heraldpubs.com/2021/09/20/state-reaches-first-union-agreement-for-vaccine-mandate-in-illinois-congregate-facilities/" rel="bookmark" title="State Reaches First Union Agreement For Vaccine Mandate in Illinois’ Congregate Facilities"> <img width="288" height="189" src="https://www.heraldpubs.com/wp-content/uploads/2020/08/COVID-19-Card-3.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.heraldpubs.com/2021/09/20/state-reaches-first-union-agreement-for-vaccine-mandate-in-illinois-congregate-facilities/" rel="bookmark" title="State Reaches First Union Agreement For Vaccine Mandate in Illinois’ Congregate Facilities">State Reaches First Union Agreement For Vaccine Mandate in Illinois’ Congregate Facilities</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 20, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.heraldpubs.com/2021/09/20/state-reaches-first-union-agreement-for-vaccine-mandate-in-illinois-congregate-facilities/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.heraldpubs.com/2021/09/17/new-boeing-facility-to-be-built-in-mascoutah/" rel="bookmark" title="New Boeing Facility To Be Built In Mascoutah"> <img width="300" height="300" src="https://www.heraldpubs.com/wp-content/uploads/2021/09/gov-0933-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.heraldpubs.com/2021/09/17/new-boeing-facility-to-be-built-in-mascoutah/" rel="bookmark" title="New Boeing Facility To Be Built In Mascoutah">New Boeing Facility To Be Built In Mascoutah</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 17, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.heraldpubs.com/2021/09/17/new-boeing-facility-to-be-built-in-mascoutah/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.heraldpubs.com/2021/09/16/bump-in-beef-sales-to-china-expected-to-continue/" rel="bookmark" title="Bump in beef sales to China expected to continue"> <img width="300" height="300" src="https://www.heraldpubs.com/wp-content/uploads/2021/09/GroundBeef-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.heraldpubs.com/2021/09/16/bump-in-beef-sales-to-china-expected-to-continue/" rel="bookmark" title="Bump in beef sales to China expected to continue">Bump in beef sales to China expected to continue</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 16, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.heraldpubs.com/2021/09/16/bump-in-beef-sales-to-china-expected-to-continue/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.heraldpubs.com/2021/09/15/massive-energy-bill-becomes-law-investing-billions-between-renewable-nuclear-sectors/" rel="bookmark" title="Massive energy bill becomes law, investing billions between renewable, nuclear sectors"> <img width="300" height="269" src="https://www.heraldpubs.com/wp-content/uploads/2021/09/gov1-copy-300x269.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.heraldpubs.com/2021/09/15/massive-energy-bill-becomes-law-investing-billions-between-renewable-nuclear-sectors/" rel="bookmark" title="Massive energy bill becomes law, investing billions between renewable, nuclear sectors">Massive energy bill becomes law, investing billions between renewable, nuclear sectors</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 15, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.heraldpubs.com/2021/09/15/massive-energy-bill-becomes-law-investing-billions-between-renewable-nuclear-sectors/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="adrotate_widgets-6" class="fl-widget widget_adrotate_widgets"><!-- Error, Ad (16) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="adrotate_widgets-4" class="fl-widget widget_adrotate_widgets"><!-- Error, Ad (14) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="adrotate_widgets-5" class="fl-widget widget_adrotate_widgets"><!-- Error, Ad (15) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="http://www.heraldpubs.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="http://www.heraldpubs.com/wp-content/uploads/2016/04/breakingNewsHeader.png" /></a></div></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  </aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-1"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Herald Publications</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-15580" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15580"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=c217e653-d6dd-4728-9c50-c9ad4133dfd2">Scott Flier</a></li> <li id="menu-item-15581" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15581"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=d5fec356-fe7f-4ae9-aba1-cf00f92d6bf4">The Herald</a></li> <li id="menu-item-15582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15582"><a target="_blank" rel="noopener noreferrer" href="http://2382.newstogo.us/editionviewer/default.aspx?Publication=2d229e9e-3c6f-4210-bf52-883dd4b47deb">The Tribune</a></li> </ul></div></aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-2"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> <div><ul class="menu"> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.heraldpubs.com/syndicated_category/united-states/">US</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.heraldpubs.com/syndicated_category/sports/">Sports</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.heraldpubs.com/syndicated_category/entertainment/">Entertainment</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.heraldpubs.com/syndicated_category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.heraldpubs.com/syndicated_category/political/">Politics</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.heraldpubs.com/syndicated_category/world/">World</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.heraldpubs.com/syndicated_category/business/">Business</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.heraldpubs.com/syndicated_category/health/">Health</a></li> </ul></div> </aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-3"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.heraldpubs.com/crossword/">Crossword Puzzle</a></li> <li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.heraldpubs.com/event-calendar/">Event Calendar</a></li> <li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218"><a href="https://www.heraldpubs.com/photos/">Photo Galleries</a></li> <li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.heraldpubs.com/poll/">Online Poll</a></li> </ul></div></aside></div> </div> </div> </div> <div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>               
</body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 4.66017413 sec
Time to load cache: 0.40106297
Cache file created on: 2021-09-20T18:55:33+00:00
Current time: 2021-09-20T19:20:08+00:00
-->